mruby 缓冲区错误漏洞 CVE-2020-15866 CNNVD-202007-1360

7.5 AV AC AU C I A
发布: 2020-07-21
修订: 2020-07-23

mruby是一款Ruby语言的轻量级实现。 mruby 2.1.2-rc及之前版本中的vm.c文件的‘mrb_yield_with_class’函数存在缓冲区错误漏洞,该漏洞源于程序没有正确检查边界。远程攻击者可借助‘stack_copy’函数利用该漏洞在系统上执行任意代码。

0%
暂无可用Exp或PoC
当前有2条受影响产品信息